# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]"
test_str = ("h1\n"
" =title\n"
" include 'atoms-square'\n"
"#container.col\n"
" if youAreUsingJade\n"
" p You are amazing\n"
" else\n"
" p Get on it!\n"
" p.\n"
" Jade is a terse and simple\n"
" templating language with a\n"
" strong focus on performance\n"
" and powerful features.\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.