Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((?:(?:https?|ftp)+(?:\:\/\/))?)+(?:(?:(?:www(?:(?:[\d]{1})?)\.|[a-z0-9-_]{1,}))+\.(?:com|me|ru|net|biz|info|fm|su|ua|to|us|[a-z]{1,5}))+(?:(?:[a-z0-9\/\?=-_.&]{1,})?)
/
ism
Input 1
1
New
Дорого времени суток, составил регулярку для парсинга ссылок вида http://example.com/ http://www.example.com/, www.example.com, example.com, example.com?act=1 и тд и тп, вот регулярка: