$re = '~^(\d{1,2}:\d{1,2};?)+$~m';
$str = '5:2;7:7;5:2;
5:2;7:7;5:2
9:9;
9:9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);