using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]";
string input = @"I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers
Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}