package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^»]+?»){3}\s*(.+?)\s*[\nÂ]`)
var str = `I need to extract the following text string using google/re2: Audiences » Affinity Categories » Food & Dining » Fast Food Cravers
Audiences » Affinity Categories » Food & Dining » Foodies Audiences » Affinity Categories » Home & Garden
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}