using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{0,50}$)^((https?:\/\/)?(www\.)?)?([a-zA-Z0-9&\-\'\+\$%_,\/;#])+\.([a-z]){2,4}$";
string input = @"www.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}