re = /^(?=.{0,50}$)^((https?:\/\/)?(www\.)?)?([a-zA-Z0-9&\-\'\+\$%_,\/;#])+\.([a-z]){2,4}$/
str = 'www.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end