#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Incident:([\s\S]*?)\tDescriptio"
Local $sString = "Bla Incident: incidente" & @CRLF & _
"en" & @CRLF & _
"varias" & @CRLF & _
"lineas" & @CRLF & _
" Description" & @CRLF & _
"Etc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")