#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+"
Local $sString = " <?xml version="1.0" encoding="utf-8"?>" & @CRLF & _
" <string xmlns=""http://tempuri.org/"">" & @CRLF & _
" <Status>{0}</Status>" & @CRLF & _
" <Currency>{1}</Currency>" & @CRLF & _
" <WalletBalance>{2}</ WalletBalance >" & @CRLF & _
" </string>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")