const regex = /(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\?xml[a-zA-Z0-9 .""\',?=-]+>[\\s]+|[\\s]+<\\?xml[a-zA-Z0-9 .""\',?=-]+>[\\s]+)|^[\\s]+', '')
const str = ` <?xml version="1.0" encoding="utf-8"?>
<string xmlns=""http://tempuri.org/"">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}