// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+"#).unwrap();
let string = " <?xml version=\"1.0\" encoding=\"utf-8\"?>
<string xmlns=\"\"http://tempuri.org/\"\">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}