import Foundation
let pattern = #"(<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+|[\s]+<\?xml[a-zA-Z0-9 .""',?=-]+>[\s]+)|^[\s]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?xml version="1.0" encoding="utf-8"?>
<string xmlns=""http://tempuri.org/"">
<Status>{0}</Status>
<Currency>{1}</Currency>
<WalletBalance>{2}</ WalletBalance >
</string>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}