#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\r?\n|\r){2,}(?!#Example-\d)"
Local $sString = "#Example-1#" & @CRLF & _
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd." & @CRLF & _
"" & @CRLF & _
"jfbgfdgdf sgdsgsd." & @CRLF & _
"#End Example-1#" & @CRLF & _
"" & @CRLF & _
"#Example-2#" & @CRLF & _
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd." & @CRLF & _
"jfbgfdgdf sgdsgsd." & @CRLF & _
"#End Example-2#"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)