re = /(\r?\n|\r){2,}(?!#Example-\d)/
str = '#Example-1#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-1#
#Example-2#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-2#'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result