const regex = /\b(?:(?:([a-z])(?=[a-z]*\1))+(?!\1))?([a-z])(?![a-z]*\2)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:([a-z])(?=[a-z]*\\1))+(?!\\1))?([a-z])(?![a-z]*\\2)', 'ig')
const str = `'NUNUMUNN' // expected output 'M'
'LOMING' // expected output 'L'
I think it's possible to do this using general string operations, but my preference is really for pure regex.
AAAAAAAAAAAAAAAAAAAAAA
AXXXXXA
XXXXXXA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}