const regex = /^[\w.-]+@[A-Za-z0-9]+\.[A-Za-z]{3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w.-]+@[A-Za-z0-9]+\\.[A-Za-z]{3}$', '')
const str = `foo@bar.baz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}