#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=.*?[a-z])(?=.*?')[a-z']+"
Local $sString = "'word'" & @CRLF & _
"'Word" & @CRLF & _
"'W'ord" & @CRLF & _
"'W'or'd" & @CRLF & _
"Word'" & @CRLF & _
"w'orD" & @CRLF & _
"w'o'r'd" & @CRLF & _
"word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")