using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(tasker 2\.5\.[0-9][0-2])|(tasker 2\.5\.[0-9])|(tasker 2\.[0-4]\.\d+)";
string input = @"tasker 2.5.9 tasker 2.5.11 tasker 2.3.2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}