re = /https?:\/\/([a-z0-9-]+\.)*mckinsey\.com(:[0-9]+)?$/m
str = 'http://mckinsey.com
https://mckinsey.com
https://abc.mckinsey.com
https://a.b.4-0-4.mckinsey.com
https://badmckinsey.com
https://bad.com?mckinsey.com
https://bad.com#mckinsey.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end