package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)&uri=(.*?)$`)
var str = `
Теперь у вас установлена новейшая сборка.
chrome-extension://klbibkeccnjlkjkiokjodocebajanakg/suspended.html#ttl=%D0%A2%D0%B5%D0%BF%D0%B5%D1%80%D1%8C%20%D1%83%20%D0%B2%D0%B0%D1%81%20%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B0%20%D0%BD%D0%BE%D0%B2%D0%B5%D0%B9%D1%88%D0%B0%D1%8F%20%D1%81%D0%B1%D0%BE%D1%80%D0%BA%D0%B0.&pos=0&uri=https://www.microsoftedgeinsider.com/ru-ru/welcome/update?channel=dev&version=84.0.508.0
Experiments
chrome-extension://klbibkeccnjlkjkiokjodocebajanakg/suspended.html#ttl=Experiments&pos=0&uri=edge://flags/#tab-groups
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}