import Foundation
let pattern = #"(\skeyword\s|\skey\s|\s(?![^[]+]$|[^{]+}$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[] []
[] keyword []
[] key []
[] ["can contain spaces"]
[] keyword ["can contain spaces"]
[] key ["can contain spaces"]
{} {}
{} keyword {}
{} key {}
{} {"can":"contain spaces"}
{} keyword {"can":"contain spaces"}
{} key {"can":"contain spaces"}
string string
string string@"$£$£~
string keyword string
string key string
{} {"can": []}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)