// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S").unwrap();
let string = "U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}