re = /^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}/m
str = '01.01.2009
01-Jan-2009
15.15.2009
05.12.2009
32.01.2009
30.01.2019
35.01.2019'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end