Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}
/
gm
Input 1
1
New
01.01.2009 01-Jan-2009 15.15.2009 05.12.2009 32.01.2009 30.01.2019 35.01.2019