# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:"
test_str = ("-- Standard (and with preceding space)\n"
"//TODO: Test\n"
" //TODO: Test\n\n"
"-- Space after //\n"
"// TODO: Test\n"
"// TODO: Test\n\n"
"-- Space befre :\n"
"//TODO : Test\n"
"//TODO : Test\n\n"
"-- Space after // AND befre :\n"
"// TODO : Test\n"
"// TODO : Test\n"
"// TODO : Test\n\n\n"
"^: \"\\/\\/\\s*TODO\\s*:\"(\\s* is \"zero or more of a space)\n\n"
"-- Misspellong TOOD\n"
"//TOOD: Test\n"
"// TOOD: Test\n"
"//TOOD : Test\n"
"//TOODO: Test\n"
"//TOODO : Test\n"
"//TODDO : Test\n"
"// TODDO : Test\n\n"
"-- Misspellong TDOO\n"
"//TDOO: Test\n"
"// TDOO: Test\n"
"// TDOO : Test\n\n\n"
"^^ [All above]: \"\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:\" (with different misspelling options)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.