import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\[\\[(?<name>.+?)\\]\\]";
final String string = "my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].\n"
+ "Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}