re = /#\[\[(?<name>.+?)\]\]/
str = 'my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end