import Foundation
let pattern = ##"#\[\[(?<name>.+?)\]\]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)