package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([a-z]{4}tion|[a-z]{6}able)\b`)
var str = `bortion
abortion
abortioq
mportable
importable
importablq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}