re = /\b([a-z]{4}tion|[a-z]{6}able)\b/m
str = 'bortion
abortion
abortioq
mportable
importable
importablq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end