#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.)\1{1,}$"
Local $sString = "john" & @CRLF & _
"wentt" & @CRLF & _
"to" & @CRLF & _
"tthe" & @CRLF & _
"moovies" & @CRLF & _
"wheree" & @CRLF & _
"he" & @CRLF & _
"abrupttly" & @CRLF & _
"pp" & @CRLF & _
"something" & @CRLF & _
"blah" & @CRLF & _
"===" & @CRLF & _
"--" & @CRLF & _
"2343" & @CRLF & _
"ajsdflja" & @CRLF & _
"aaa" & @CRLF & _
"dfs" & @CRLF & _
"aple" & @CRLF & _
"apple" & @CRLF & _
"pp" & @CRLF & _
"ppp" & @CRLF & _
"soomethings" & @CRLF & _
"please help me hello" & @CRLF & _
"hello" & @CRLF & _
"A" & @CRLF & _
"a" & @CRLF & _
"bb" & @CRLF & _
"B" & @CRLF & _
"b." & @CRLF & _
"jslkdf kk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")