use strict;
my $str = 'john
wentt
to
tthe
moovies
wheree
he
abrupttly
pp
something
blah
===
--
2343
ajsdflja
aaa
dfs
aple
apple
pp
ppp
soomethings
please help me hello
hello
A
a
bb
B
b.
jslkdf kk
';
my $regex = qr/^(.)\1{1,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}