using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<pages index=""(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)"" from=(3) to=(8) fromsection= tosection= \/>";
string substitution = @"{{Iwpages|old|$1|$2|$3||}}";
string input = @"<pages index=""La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu"" from=3 to=8 fromsection= tosection= />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}