import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<pages index=\"(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\\.djvu)\" from=(3) to=(8) fromsection= tosection= \\/>";
final String string = "<pages index=\"La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu\" from=3 to=8 fromsection= tosection= />";
final String subst = "{{Iwpages|old|$1|$2|$3||}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}