const regex = /<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\\.djvu)" from=(3) to=(8) fromsection= tosection= \\\/>', '')
const str = `<pages index="La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu" from=3 to=8 fromsection= tosection= />`;
const subst = `{{Iwpages|old|$1|$2|$3||}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);