use strict;
my $str = '<pages index="La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu" from=3 to=8 fromsection= tosection= />';
my $regex = qr/<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>/p;
my $subst = '{{Iwpages|old|$1|$2|$3||}}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";