#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)"
Local $sString = "555-555-5555" & @CRLF & _
"" & @CRLF & _
"(555)555-5555" & @CRLF & _
"" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"" & @CRLF & _
"555 555 5555" & @CRLF & _
"" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"" & @CRLF & _
"800-692-7753" & @CRLF & _
"" & @CRLF & _
"6505552368" & @CRLF & _
"" & @CRLF & _
"-1 (757) 622-7382" & @CRLF & _
"" & @CRLF & _
"555)-555-5555" & @CRLF & _
"" & @CRLF & _
"(555-555-5555" & @CRLF & _
"" & @CRLF & _
"1 (555) 555-5555" & @CRLF & _
"" & @CRLF & _
"8oo-six427676;laskdjf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")