import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(1?)(\\s?)([\\s]?)((\\(\\d{3}\\))|(\\d{3}))([\\s]?)([\\s-]?)(\\d{3})([\\s-]?)(\\d{4})+$)";
final String string = "555-555-5555\n\n"
+ "(555)555-5555\n\n"
+ "(555) 555-5555\n\n"
+ "555 555 5555\n\n"
+ "1 555 555 5555\n\n"
+ "800-692-7753\n\n"
+ "6505552368\n\n"
+ "-1 (757) 622-7382\n\n"
+ "555)-555-5555\n\n"
+ "(555-555-5555\n\n"
+ "1 (555) 555-5555\n\n"
+ "8oo-six427676;laskdjf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}