# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=id=\"_wpnonce\" name=\"_wpnonce\" value=\").*?(?=\")"
test_str = ("<form method=\"post\" enctype=\"multipart/form-data\" class=\"wp-upload-form\" action=\"http://localhost/wp-admin/update.php?action=upload-plugin\">\n"
" <input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"a7a9167537\"><input type=\"hidden\" name=\"_wp_http_referer\" value=\"/wp-admin/plugin-install.php?tab=upload\"> <label class=\"screen-reader-text\" for=\"pluginzip\">Plugin zip file</label>\n"
" <input type=\"file\" id=\"pluginzip\" name=\"pluginzip\">\n"
" <input type=\"submit\" name=\"install-plugin-submit\" id=\"install-plugin-submit\" class=\"button\" value=\"Install Now\" disabled=\"\"> </form>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.