// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\r\n]{5})").unwrap();
let string = " aaa
bbbbbbb
cc
dddddddddddd";
let substitution = "$1\\r\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}