import Foundation
let pattern = #"([^\r\n]{5})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
aaa
bbbbbbb
cc
dddddddddddd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\r\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)