# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\W+/_/gm;t' <<< "feature/my-feature-1130"