$re = '/\W+/m';
$str = 'feature/my-feature-1130';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;