import re
regex = re.compile(r"\W+", flags=re.MULTILINE)
test_str = "feature/my-feature-1130"
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)