re = /(<)[^<]+?(?=(facebook\.com))[^]+?(\/a>)/mi
str = '<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 14 (filtered medium)">
<!--[if !mso]><style>v\\:* {behavior:url(#default#VML);}
o\\:* {behavior:url(#default#VML);}
w\\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]--><style><!--
/* Font Definitions */
@font-face
{font-family:Wingdings;
panose-1:5 0 0 0 0 0 0 0 0 0;}
@font-face
{font-family:Wingdings;
panose-1:5 0 0 0 0 0 0 0 0 0;}
@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
{font-family:Tahoma;
panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
{font-family:"Arial Black";
panose-1:2 11 10 4 2 1 2 2 2 4;}
@font-face
{font-family:Georgia;
panose-1:2 4 5 2 5 4 5 2 3 3;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0cm;
margin-bottom:.0001pt;
font-size:11.0pt;
font-family:"Calibri","sans-serif";
mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
{mso-style-priority:99;
color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{mso-style-priority:99;
color:purple;
text-decoration:underline;}
p
{mso-style-priority:99;
mso-margin-top-alt:auto;
margin-right:0cm;
mso-margin-bottom-alt:auto;
margin-left:0cm;
font-size:12.0pt;
font-family:"Times New Roman","serif";}
span.EmailStyle17
{mso-style-type:personal;
font-family:"Georgia","serif";
color:windowtext;}
span.EmailStyle20
{mso-style-type:personal-reply;
font-family:"Calibri","sans-serif";
color:#1F497D;}
.MsoChpDefault
{mso-style-type:export-only;
font-size:10.0pt;}
@page WordSection1
{size:612.0pt 792.0pt;
margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
{page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-AU" link="blue" vlink="purple">
<!--ppd39--><!--ppd37-->
<div class="WordSection1">
<p class="MsoNormal"><span style="color:#1F497D">Testing what we can do with the footers.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><a href="Http://mail.google.com">Http://mail.google.com</a><o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D">That was a link<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<div><br>
<br>
<span id="ppe_37">
<div align="left">
<p><font size="2" face="Arial"><strong><font color="black">Russell Miller</font><br>
<font color="black"></font> <br>
</strong></font><font color="#c0c0c0" size="2" face="Arial Black">P</font> <font size="2" face="Arial">
<font color="black"></font><font color="black"></font> </font><font color="#c0c0c0" size="2" face="Arial Black">F</font>
<font size="2" face="Arial"><font color="#000000" face="Arial"><br>
<br>
Brisbane QLD 4170 </font> <br>
<span><font color="#c0c0c0" face="Arial Black">E </font><a href="mailto:R.Miller@endeavour.com.au"><font color="#000000" size="2" face="Arial">R.Miller@endeavour.com.au</font></a>
<font color="#c0c0c0" size="2" face="Arial Black">W <a href="http://www.endeavour.com.au/">
<font color="#000000" face="Arial">www.endeavour.com.au</font></a></font> <a href="https://www.qld.gov.au/about/events-awards-honours/awards/qld-greats-awards/">
<img border="0" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/email-qld-greats-recognition-mark.ashx"></a>
<a href="https://www.facebook.com/endeavourfoundation"><img border="0" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/facebook.ashx"></a><br>
<br>
<a href="https://www.facebook.com/pages/The-Labels-Shop/1416142462035315?ref=ts&fref=ts"><img border="0" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/Labels-Shop-Email-Signature">
</a></span></font></p>
</div>
</span>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:10.0pt;font-family:"Tahoma","sans-serif";mso-fareast-language:EN-AU">From:</span></b><span lang="EN-US" style="font-size:10.0pt;font-family:"Tahoma","sans-serif";mso-fareast-language:EN-AU"> Yvette
Gorlee <br>
<b>Sent:</b> Tuesday, 2 June 2015 11:03 AM<br>
<b>To:</b> Russell Miller<br>
<b>Subject:</b> Missing Address in Location<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-family:"Georgia","serif"">Hi Russell<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Georgia","serif""><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Georgia","serif"">This is the address missing in the Location Box – Please add: 1 Westmoreland Street, Rockhampton QLD 4701.
<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Georgia","serif""><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Georgia","serif";mso-fareast-language:EN-AU">Thank-you
</span><span style="font-family:Wingdings;mso-fareast-language:EN-AU">J</span><span style="font-family:"Georgia","serif";mso-fareast-language:EN-AU"><o:p></o:p></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-size:12.0pt;font-family:"Times New Roman","serif";mso-fareast-language:EN-AU"><br>
<br>
<br>
<o:p></o:p></span></p>
<p><strong><span style="font-size:10.0pt;font-family:"Arial","sans-serif";color:black">Yvette Gorlee</span></strong><b><span style="font-size:10.0pt;font-family:"Arial","sans-serif""><br>
<strong><span style="font-family:"Arial","sans-serif";color:black">Helpdesk Officer</span></strong><strong><span style="font-family:"Arial","sans-serif""> </span></strong><br>
</span></b><span style="font-size:10.0pt;font-family:"Arial Black","sans-serif";color:silver">P</span>
<span style="font-size:10.0pt;font-family:"Arial","sans-serif";color:black">(07) 3908 7299</span><span style="font-size:10.0pt;font-family:"Arial","sans-serif"">
</span><span style="font-size:10.0pt;font-family:"Arial Black","sans-serif";color:silver">F</span>
<span style="font-size:10.0pt;font-family:"Arial","sans-serif";color:black">(07) 3908 7128<br>
50 Southgate Ave, Cannon Hill QLD 4170 <br>
PO Box 3555 Tingalpa QLD 4173 Australia </span><span style="font-size:10.0pt;font-family:"Arial","sans-serif""> <br>
</span><span style="font-size:10.0pt;font-family:"Arial Black","sans-serif";color:silver">E
</span><span style="font-size:10.0pt;font-family:"Arial","sans-serif""><a href="mailto:y.gorlee@endeavour.com.au"><span style="color:black">y.gorlee@endeavour.com.au</span></a>
</span><span style="font-size:10.0pt;font-family:"Arial Black","sans-serif";color:silver">W
<a href="http://www.endeavour.com.au/"><span style="font-family:"Arial","sans-serif";color:black">www.endeavour.com.au</span></a></span><span style="font-size:10.0pt;font-family:"Arial","sans-serif"">
<a href="https://www.qld.gov.au/about/events-awards-honours/awards/qld-greats-awards/">
<span style="text-decoration:none"><img border="0" id="_x0000_i1025" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/email-qld-greats-recognition-mark.ashx"></span></a>
<a href="https://www.facebook.com/endeavourfoundation"><span style="text-decoration:none"><img border="0" id="_x0000_i1026" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/facebook.ashx"></span></a><br>
<br>
<a href="https://gala.endeavour.com.au"><span style="text-decoration:none"><img border="0" id="_x0000_i1027" src="http://www.endeavour.com.au/~/media/Images/EmailSignature/Anniversary-Gala-Email-Signature"></span></a></span><o:p></o:p></p>
</div>
<br>
<br>
<span id="ppe_39"><font color="silver"><span style="FONT-SIZE: 7.5pt; FONT-FAMILY: Verdana; COLOR: gray"><font size="1">Disclaimer - June 2, 2015</font></font></span>
<p></p>
<font size="1"><font color="gray" face="Verdana"><span style="FONT-SIZE: 7.5pt; FONT-FAMILY: Verdana; COLOR: gray">This email and any files
<font size="1">transmitted</font> with it are confidential and intended solely for
<strong>endeavourdev@service-now.com</strong></span></font> <font color="gray" face="Verdana">
<span style="FONT-SIZE: 7.5pt; FONT-FAMILY: Verdana; COLOR: gray">. If you are not the named addressee you should not disseminate, distribute, copy or alter this email. Any views or opinions presented in this email are solely those of the author and might not
represent those of Endeavour. Warning: Although Endeavour has taken reasonable precautions to ensure no viruses are present in this email, the company cannot accept responsibility for any loss or damage arising from the use of this email or attachments.
<p>Endeavour Foundation respects your privacy. All personal information we hold about you is kept confidential, according to Australian privacy law.<br>
For more information about Endeavour Foundation and privacy, visit our website – <a href="http://www.endeavour.com.au">
www.endeavour.com.au</a>.</p>
</span></font></font></span>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end