package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)r"[\d]{9}"`)
var str = `"string": "Example phrasing:",
"create-email": "dadowns1159@gmail.com",
"create-time": 1602417978844,
"children": [
this: "example: value"
that: "random: value"
789654123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}