import Foundation
let pattern = #"r"[\d]{9}""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"string": "Example phrasing:",
"create-email": "dadowns1159@gmail.com",
"create-time": 1602417978844,
"children": [
this: "example: value"
that: "random: value"
789654123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}