#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\(\*(?:(?!\(\*|\*\)).)*?\*\)"
Local $sString = "1. (*comment*)" & @CRLF & _
" some code that should not be matched" & @CRLF & _
"" & @CRLF & _
"2. (****comment****)" & @CRLF & _
" some code that should not be matched" & @CRLF & _
"" & @CRLF & _
"3. (*comment (*comment inside comment*) comment*)" & @CRLF & _
" some code that should not be matched" & @CRLF & _
"" & @CRLF & _
"4. (**) some code that should not be matched (***)" & @CRLF & _
"" & @CRLF & _
"5. (*multi-" & @CRLF & _
" line-" & @CRLF & _
" comment*) some code that should not be matched" & @CRLF & _
"" & @CRLF & _
"6. (*comment (with parentheses)*)" & @CRLF & _
" some code that should not be matched" & @CRLF & _
"" & @CRLF & _
"7. some code that (*comment*) should (not) be matched (*comment*)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")