import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\*(?:(?!\\(\\*|\\*\\)).)*?\\*\\)";
final String string = "1. (*comment*)\n"
+ " some code that should not be matched\n\n"
+ "2. (****comment****)\n"
+ " some code that should not be matched\n\n"
+ "3. (*comment (*comment inside comment*) comment*)\n"
+ " some code that should not be matched\n\n"
+ "4. (**) some code that should not be matched (***)\n\n"
+ "5. (*multi-\n"
+ " line-\n"
+ " comment*) some code that should not be matched\n\n"
+ "6. (*comment (with parentheses)*)\n"
+ " some code that should not be matched\n\n"
+ "7. some code that (*comment*) should (not) be matched (*comment*)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}