# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[blargh=(?|"(\d+)"|("[^"]*"))\]/<potato chips=#\1#>/gm;t' <<< "[blargh=\"5\"] [blargh=\"97\"] [blargh=\"StackOverflow\"]
"